CLO HELP CENTER

有什么能为您效劳的吗?

导入/导出3D 文件 (OBJ)

关注

内容列表 

导入/导出OBJ

添加服装

读取为Morph Target

导入为附件

读取虚拟模特

 

导入/导出OBJ

目的

保存场景、道具、虚拟模特以及虚拟模特周围环境时使用OBJ格式。 
如果OBJ格式的文件是一个模特,那么该OBJ格式可以穿着服装,但是导入为场景或附件时,服装会因为识别不了OBJ文件而发生穿透现象。把OBJ导入为附件,详情请参阅导入为附件

此外,具有相同网格结构(网状结构表示3D对象)的OBJ文件能够被“变形”以改变虚拟模特姿势。“变形”是指将一个物体的姿势缓慢地变成统一物体的另一姿势,该功能主要勇于改变虚拟模特的姿势或体型。此功能在更改虚拟模特的穿着姿势时非常有用。有关详细说明,请参阅
读取为Morph Target

CLO中制作的服装可以导出为OBJ格式的文件,也能互换使用到其他3D软件中。当服装导出OBJ文件,会同时生成MTL文件,MTL文件保存的是在服装上设置的材质信息。


访问路径

导入OBJ

主菜单 ▶ 文件 ▶ 导入 ▶ OBJ  


导入(添加)OBJ

主菜单 ▶ 文件 ▶ 导入(添加) ▶ OBJ 


导出OBJ

主菜单 ▶ 文件 ▶ 导出 ▶ OBJ


导出OBJ(选定的)

主菜单 ▶ 文件 ▶ 导出 ▶ OBJ (选定的)


操作

导入OBJ

  1. 请按以下步骤操作:

    主菜单 ▶ 文件 ▶ 导入 ▶ OBJ

    → 出现打开文件窗口

  2. 选择要导入的文件点击确认
    → 弹出导入OBJ窗口。

  3. 设置细节并点击确认

    ※ 参考: 

    导入OBJ细节项目设置

    对象类型

    读取虚拟模特

      读取虚拟模特会替代原先默认的虚拟模特。

      增加安排点&安排板:打开此选项可生成适合导入的虚拟模特的安排板和安排点(ver4.2.0)。
      ※参考:
    该选项式作用于导入的OBJ是T_Pose或者A_Pose姿势时,否则会出现以下错误信息提示:
      “安排点不适用于该虚拟模特,虚拟模特必须为T_Pose或者A_Pose。”

    00__1_.jpg  

    导入为附件   因为没有冲突处理,OBJ会穿透服装 (ver3.0.0)。
    导入为附件

      将OBJ文件读取为3D服装。

      根据UV图勾勒2D板片:打开此选项,可基于UV图信息生成板片 (ver4.2.0)。

    读取为Morph Target   将虚拟模特的初始姿式改变为指定姿势。输入变形体帧数,帧数越高,变形的速度越慢。
    比例   输入精确比例或者选择所需的单位。
    轴转换   变换物体的各个轴向。
      如果导入的OBJ在地面以下,请打开将底部对齐地面选项,使OBJ文件在地面以上 (ver4.2.0)。


导入(添加)OBJ

  1. 请按以下步骤操作:

    主菜单文件导入 (添加) OBJ 

    → 弹出添加文件窗口。

  2. 设置细节并点击确认

导出OBJ

  1. 请按以下步骤操作:

    主菜单 文件 导出 OBJ (选定的)

    → 弹出保存文件窗口。

  2. 选择要保存的路径点击保存

    → 弹出导出OBJ窗口。

  3. 设置细节并点击确认

    ※ 参考: 

    导出OBJ设置

    对象

     

     

     

      选择所有板片:选择/反选所有板片。 可通过点击右边的下拉菜单选择特定的板片 (ver2.2.0)。
     
      ※ 参考:
     如果使用OBJ(选定的),在3D和2D窗口中被选择的板片将会在复选框中被自动选择。

     
      选择虚拟模特
    :选择/反选所有虚拟模特/物体。可通过点击右边的下拉菜单选择特定的物体 (v
    er2.2.0)。

      选择所有贴图/明线:选择/反选所有贴图/明线。可通过点击右边的下拉菜单选择特定的贴图/明线 (ver2.2.0)。

      单个目标

      选择的物体会作为单个对象导出。single2.jpg

      多个对象

      选择的物体以多个对象导出。  multiply2.jpg

      解除合并

      板片缝合线的连接部分的点会分开导出。  

    ____.jpg

      合并

      板片缝合线的连接部分的点会合并成一个点导出。 

    __.jpg

    结合被选择的板片:将选择的板片基于缝纫线结合在一起。

      薄的

      尽管预先设定了渲染厚度的值,但只要选择薄的选项即可。

      __.jpg

      厚的

      将板片以调整过渲染厚度的形式导出。

      ※ 参考: 当板片网格为四边形时可导出厚度 (ver2.3.0)。

      __.jpg

    统一的UV坐标:导出所有适合于UV坐标的服装图片和纹理数据,范围从0到1。
    包括内部图形:导出文件包含内部线和内部图形 (ver2.3.0)。
    比例   通过输入数字或者从导入文件单位中选择所需的单位,可以调整导出文件的大小。
    轴转换   变换物体的各个轴向。
    文件   保存纹理文件 (*.zip):导出动画时,obj文件、mtl文件以及服装文件中保存的纹理图片会压缩成一个文件导出。
      集合纹理和颜色:在纹理上应用颜色后,导出时颜色和纹理可一起导出 (ver4.2.0)。
      消除环境贴图和颜色 (Modo): 导出时可消除环境贴图和颜色 (ver4.2.0)。
      保存Alpha图:导出时包含Alpha图 (ver4.2.0)。
      保存Meta数据 (*.xml):将服装班牌(Mesh)、物理属性、缝纫信息会以Meta数据导出 (ver2.3.0)。
      将颜色和纹理合在一起: 结合并保存服装的纹理图像和颜色 (ver2.2.0)。
      环境反射色除外 (Modo专用):排除周围的颜色值保存材料


    ※ 参考:

    导出OBJ更新

    导出OBJ时可包括内部线/图形(包含FBX)。

    四边形板片导出厚度。
    分开导出正侧背网格。
 

加服装

目的

导入并模拟在其他3D软件中(Maya, 3DS MAX等)的OBJ文件。


访问路径

主菜单 文件 ▶ 导入 (添加) ▶ 添加服装


操作

  1. 请按以下步骤操作:

    主菜单文件导入 (添加) 添加服装

    → 弹出打开文件菜单。

  2. 选择导入的文件并点击打开

    → 弹出添加服装窗口。

  3. 设置细节并点击确认


读取为Morph Target

目的

读取为Morph Target是使用两种OBJ文件来缓慢地改变虚拟模特姿势。使用虚拟模特编辑器可以修改CLO的默认模特,或使用显示X-Ray结合处更改虚拟模特动作,其他3D软件可能没有设计模特的基本关节,在创建兼容的COLLADA文件时可能会丢失部分。因此,这个菜单可以用来改变虚拟模特的体型。为了改变虚拟模特的姿势,至少需要两个相同网格数的OBJ文件。使用这个功能可以将其他3D软件中的OBJ文件导入为虚拟模特,并穿着服装或更改它们的姿势。

00000.png


访问路径

导入OBJ

主菜单 ▶ 文件 ▶ 导入 ▶ OBJ 

读取为Morph Target

导入OBJ设置窗口 ▶ 物体类型 ▶ 读取为Morph Target


操作

  1. 选择两个OBJ文件来更改虚拟模特姿势。

  2. 请按以下步骤操作:

    主菜单 ▶ 文件 ▶ 导入 ▶ OBJ 

    → 弹出打开文件窗口。

  3. 选择需要被更改姿势的OBJ文件并点击确认
    → 出现导入OBJ窗口。

  4. 设置细节并点击确认

  5. 请按以下步骤操作:

    主菜单 ▶ 文件 ▶ 导入 ▶ OBJ 

    → 弹出打开文件窗口。

  6. 选择更改动作后的OBJ文件并点击确认

    → 弹出Morph Target窗口。

  7. 请按以下步骤操作:

    导入OBJ设置菜单 物体类型  读取为Morph Target

  8. 设置细节并点击确认

    ※ 参考: 带有特殊符号的文件无法打开。

 

导入为附件

目的

使用其他3D软件中设计的OBJ文件可制作附件和虚拟模特。当家再一个文件为虚拟模特时,服装将该对象识别为虚拟模特并穿着与虚拟模特身上,但是当作为附件导入时,服装不能识别,所以为穿透附件。


访问路径

导入OBJ

主菜单 ▶ 文件 ▶ 导入 ▶ OBJ 

导入为附件

导入OBJ设置窗口 ▶ 物体类型 ▶ 导入为附件


操作

  1. 请按以下步骤操作:

    主菜单 
    文件导入OBJ 

    → 弹出打开文件窗口。

  2. 选择需要导入的文件并点击打开
    → 弹出导入OBJ窗口。

  3. 在物体类型中选择导入附件

  4. 设置细节并点击确认

     

读取虚拟模特

目的

在其他3D软件中生成的OBJ文件可导入为虚拟模特在CLO中使用。当导入为虚拟模特时,服装能识别该OBJ文件并穿着于虚拟模特。


访问路径

导入OBJ

主菜单 ▶ 文件 ▶ 导入 ▶ OBJ 

读取虚拟模特

导入OBJ设置窗口 ▶ 物体类型 ▶ 读取虚拟模特


操作

  1. 请按以下步骤操作:

    主菜单 
    文件导入OBJ 

    → 弹出打开文件窗口。

  2. 选择导入的文件并点击确认

    → 弹出导入OBJ文件窗口。

  3. 在物体类型中选择读取虚拟模特

  4. 设置细节并点击确认

 

这篇文章有帮助吗?
2 人中有 2 人觉得有帮助

评论

登录写评论。