CLO HELP CENTER

How can we help you?

CLO API/SDK 가이드

팔로우

Objective

하기에 링크된 API 패키지를 다운로드 후 해당 문서에 첨부된 API/SDK 가이드를 참고하여 임의로 필요한 기능을 개발하고 CLO에 추가할 수 있습니다.

각 버전에 알맞는 API를 사용해야 CLO Plugin을 개발할 수 있습니다.

 

CLO Ver.

Windows API

Mac API

Manual

5.0 Official Release

V1.1 (download)

V0.5 (download)

manual

 

5.0.156 Official Patch

5.0.162 Official Patch

V1.2 (download)

V0.6 (download)

manual

 

5.0.178 Official Patch

V2.0 (download)

manual

 

5.0.202 Official Patch

V2.2 (download)

manual

5.1.290 Official Release

5.1.312 Official Patch
5.1.320 Official Patch
5.1.330 Official Patch

V2.3 (download) 

manual

 

5.1.436 Official Patch 

V2.5 (download)

manual

 

5.1.474 Official Patch

V2.6 (download)

manual

5.2.142 Official Release 

V2.7 (download)

manual

 

5.2.260 Official Patch 

5.2.268 Official Patch 

5.2.284 Official Patch

5.2.318 Official Patch

5.2.334 Official Patch 

V2.8 (S3 / Ali)

manual (S3 / Ali)

 

5.2.356 Official Patch 

5.2.364 Official Patch 

5.2.382 Official Patch 

V2.9 (S3 / Ali)

manual (S3 / Ali

6.0.328 Official Release (Latest)

V3.0 (S3 / Ali)

manual (S3 / Ali

 

※ 참조:

  • CLO 5.1.290 버전은 CLO API/SDK V2.3을 지원합니다. Windows OS에서는 기존에 빌드해 두신 Plug-in dll을 그대로 이용하실 수 있습니다. 새로운 API 기능을 이용하시려면 V2.3을 다운로드 받으신 후 새로 빌드하여야 합니다.

  • Mac OS를 사용하시는 경우, API/SDK V2.2 이전 버젼으로 제작한 Plug-in dylib을 사용하실 수 없습니다. V2.3을 다운로드 받아 새로 빌드하시기 바랍니다.

  • CLO 5.1.436은 CLO API/SDK V2.5로 작성된 플러그인(.dll/.dylib)을 지원합니다. 예전 버젼(V2.3 이전)으로 빌드한 플러그인은 제대로 동작하지 않을 수 있으니, 최신 버젼의 API/SDK에서 새로 빌드하여 사용하시기 바랍니다.
    Unicode 지원 API 함수들이 추가되었습니다.
    다만, CLO의 현재 버젼은 Unicode와 호환되지 않는 기능이 있기 때문에(파일 저장 / 로드 / 내보내기 등), Unicode 관련 API 함수를 사용하시는 경우, 예상한 동작과 다른 결과가 있을 수도 있습니다. 이 경우, ASCII 호환 코드를 사용해주시기 바랍니다.

 

도움이 되었습니까?
8명 중 4명이 도움이 되었다고 했습니다.

댓글

댓글을 남기려면 로그인하세요.