CLO HELP CENTER

How can we help you?

3D 파일(OBJ) 불러오기/내보내기

팔로우

List of Contents 

OBJ 불러오기/내보내기

의상으로 불러오기

몰프 대상으로 불러오기

부자재로 불러오기

아바타로 불러오기

 

OBJ 불러오기/내보내기

Objective

OBJ 파일은 아바타와 주변 환경을 구성하는 배경, 소품을 저장할 때 사용됩니다. OBJ의 타입이 아바타일 경우 OBJ 파일에 의상을 입힐 수 있지만 배경이나 소품일 경우에는 OBJ 파일이 물체로 인식되지 못하기 때문에 의상이 물체에 입혀지지 않고 그대로 통과합니다. OBJ 파일을 배경/소품으로 사용하는 자세한 방법은 이 매뉴얼의 부자재로 불러오기를 참고하십시오.

또한, 동일한 메시구조(3D 물체를 표현하는 그물모양 구조)를 가진 OBJ 파일들을 “몰프(Morph)”하여 아바타의 외형을 변형할 수 있습니다. “몰핑”이란 하나의 오브젝트에서 다른 오브젝트로 그 외형을 서서히 바꾸는 것을 말하며, 이 기능을 이용해 아바타의 포즈나 신체 체형을 변형할 수 있습니다. 이 기능은 의상을 입힌 아바타의 포즈를 바꾸는 데 유용합니다. 자세한 사용 방법은 이 매뉴얼의 몰프 대상으로 불러오기 참고하십시오.

CLO 3D/MD에서 제작된 의상은 OBJ 파일 포맷으로 익스포트해 다른 3D 소프트웨어와 호환하여 사용할 수 있습니다.의상을 OBJ파일로 익스포트하면 MTL파일이 함께 생성되며 이 MTL파일은 의상에 설정된 재질 정보를 저장합니다. 


Location

OBJ 불러오기

메인 메뉴 ▶ 파일 ▶ 불러오기 ▶ OBJ  


OBJ 추가로 불러오기

메인 메뉴 ▶ 파일 ▶ 불러오기(추가) ▶ OBJ 

OBJ 내보내기

메인 메뉴 ▶ 파일 ▶ 내보내기 ▶ OBJ


선택한 OBJ 내보내기

메인 메뉴 ▶ 파일 ▶ 내보내기 ▶ OBJ (선택 패턴)


Operation

OBJ 불러오기

  1. 해당 경로를 따라갑니다:

    메인 메뉴 ▶ 파일 ▶ 불러오기 ▶ OBJ  

    → 파일 열기 창이 열립니다.

  2. 원하는 파일을 선택하고 확인을 클릭합니다.
    → OBJ 불러오기 창이 나타납니다.

  3. 세부 항목을 설정하고 확인을 클릭합니다.

    ※ 참조: 

    OBJ 불러오기 옵션 설정

    물체 유형

    아바타로
    불러오기

      오브젝트를 아바타로 불러오게 되면, 기존의 아바타는 사라지고 불러오는
      파일로 아바타가 대체됩니다.

      Add Arrangement Points & BVs 옵션을 선택하면 자동으로 불러오는 OBJ에 맞는 배치판이 생성됩니다 (ver4.2.0).
      ※참조: 불러오는 오브젝트는 T 혹은 A 포즈일 경우에만 정상작동하며, 배치판이 자동 생성되지 못할 경우 아래와 같은 경고 창이 나타납니다.
      "Arrangement Points were not fitted to the avatar. The avatar must be in a T-pose or A-pose."

    00__1_.jpg

    부자재로
    불러오기
      오브젝트를 부자재로 불러오게 되면 의상과 충돌처리가 되지 않아
      시뮬레이션 오브젝트가 의상을 통과하게 됩니다 (ver3.0.0).
    의상으로
    불러오기
      오브젝트를 의상으로 불러옵니다.

      Trace 2D Patterns from UV Map 옵션을 선택하면 UV 맵의 정보를 기반으로 패턴이 자동 생성됩니다 (ver4.2.0).
    몰프 대상으로
    불러오기
      기존의 오브젝트에서 몰프 대상으로 지정된 오브젝트로 몰핑합니다.

      "몰핑 프레임 수"에 트렌지션 프레임 수를 입력합니다.
      프레임 수가 높을수록 몰핑이 서서히 이뤄집니다.
    크기   수치를 직접 입력하거나 원하는 단위를 선택합니다.
    축 전환   오브젝트의 각 축의 방향을 변경합니다.
    이동

      오브젝트가 불러와질 위치를 설정합니다.
      오브젝트가 지면 아래에 위치할 경우, 지면 중심으로 이동 옵션을 클릭하면 오브젝트가 지면 위로 불러와집니다 (ver4.2.0).



OBJ 추가로 불러오기

  1. 해당 경로를 따라갑니다:

    메인 메뉴 ▶ 파일 ▶ 불러오기(추가) ▶ OBJ

    → 파일 추가 창이 열립니다.

  2. OBJ 불러오기(Import)와 마찬가지로 세부 항목을 설정하고 확인을 클릭합니다.

OBJ 내보내기

  1. 해당 경로를 따라갑니다:

    메인 메뉴 ▶ 파일 ▶ 내보내기 ▶ OBJ/OBJ(선택 패턴)

    → 파일 저장 창이 열립니다.
  2. 원하는 위치를 선택하고 저장을 클릭합니다.
    → OBJ 내보내기 창이 나타납니다

  3. 세부 항목을 설정하고 확인를 클릭합니다.

    ※ 참조: 

    OBJ 내보내기 옵션 설정

    물체

     

     

     

      모든 패턴 선택: 모든 패턴을 선택하거나 해지합니다.
      우측 드롭다운 메뉴를 클릭하면 하위 목록이 나타나는데,
      여기서 개별적으로 선택할 수 있습니다 (ver2.2.0).
     
      ※ 참조:
    메뉴에서 OBJ(Selected)를 선택했을 경우 3D, 2D Window에서

      선택한 패턴들이 체크되어 들어옵니다.
     
      모든 아바타 선택:
    모든 아바타/물체를 선택하거나 해지합니다. 우측 드롭다운 메뉴를

      클릭하면 하위 목록이 나타나는데, 여기서 개별적으로 선택할 수 있습니다 (ver2.2.0).
      모든 그래픽과 탑스티치 선택: 모든 스티치를 선택하거나 해지합니다. 우측 드롭다운 메뉴를
      클릭하면 하위 목록이 나타나는데, 여기서 개별적으로 선택할 수 있습니다 (ver2.2.0).

      하나의 객체로

      선택한 물체를 하나의 객체로 내보냅니다.

      

      여러 개의 객체로

      선택한 물체를 각각의 개체로 내보냅니다.

      

      개별 (Unweld)

      패턴에 재봉선이 설정되어 연결된 부분의
      Vertex(Mesh의 점)들을 각각의 개체로
      내보냅니다.

      

      병합 (weld)

      패턴에 재봉선이 설정되어 연결된 부분의
      Vertex(Mesh의 점)들을 하나의 점으로 합칩니다.

      

    선택된 패턴 병합 (Weld): 선택한 패턴끼리 재봉선으로 연결된 부분을 병합(Weld)합니다.

      Thin

      사전에 렌더링 두께의 값을 높여도
      Thin Option을 설정하면 두께가
      지오메트리로(Geometry)로 내보내지지
      않습니다.

      

      Thick 

      렌더링 두께의 값을 지오메트리로(Geometry)로
      내보냅니다.

      ※ 참조: 2.3.0 버전 이후로 패턴의 메시가 쿼드
      (Quad)일때도 두께를 내보낼 수 있습니다 (ver2.2.0).

      

      통합 UV좌표
    내부 도형 포함: 의상에 포함된 내부선분의 정보도 함께 익스포트합니다 (ver2.3.0).
    크기   수치를 입력하거나 "불러올 파일의 단위"에서 원하는 단위를 선택하여 익스포트하는
      파일의 스케일을 조절합니다.
    축전환   오브젝트의 각 축의 방향을 변경합니다.
    파일

    텍스처 함께 저장 (ZIP): Exports the .obj file, .mtl file, and texture images used in the garment as one compressed file when exporting animation. 

       색상과 텍스처 합치기: 함께 저장할 텍스처에 색상이 적용되어있는경우, 색상과 텍스처가 합쳐진 상태로 저장됩니다 (ver4.2.0).
       Exclude Ambient Map & Color (Modo): 환경 반사맵과 환경 반사 색상은 제외됩니다 (ver4.2.0).
       Save with Alpha Map: 알파맵이 함께 저장됩니다 (ver4.2.0).

    메타 데이터 함께 저장 (XML): 의상의 패턴(Mesh), 물성, 재봉 정보를 Meta 정보로 내보냅니다 (ver2.3.0.) 의상에 설정한 텍스처 이미지와 컬러를 합쳐 하나의 이미지로 저장합니다 (ver2.2.0.) 



    ※ 참조: 

    OBJ 내보내기 개선사항

    내부선분 정보도 함께 내보냄 (FBX도 해당됨)

    사각 메시(Quad Mesh)인 경우에도 두께 있게 내보냄.
    앞, 옆, 뒤 메시 따로 내보냄.
 

의상으로 불러오기

Objective

다른 3D 소프트웨어 (Maya, 3ds MAX 등)에서 제작한 의상을 OBJ로 임포트 해 시뮬레이션 할 수 있습니다. 


Location

메인 메뉴 ▶ 파일 ▶ 불러오기(추가) ▶ OBJ를 의상으로


Operation

  1. 해당 경로를 따라갑니다: 

    메인 메뉴 ▶ 파일 ▶ 불러오기(추가) ▶ OBJ를 의상으로

    → 파일 열기 창이 열립니다.

  2. 원하는 파일을 선택하고 확인을 클릭합니다.
    → OBJ를 의상으로 불러오기 창이 나타납니다.

  3. 세부 항목을 설정하고 확인을 클릭합니다.


몰프 대상으로 불러오기

Objective

몰프는 서로 다른 형태의 OBJ파일을 이용해 오브젝트의 외형을 서서히 바꾸는 것을 말합니다.
CLO 3D에서 기본으로 제공하는 아바타는 “아바타 사이즈 변형”메뉴로 아바타의 신체를 변형하거나,
“X-Ray 관절 보기”기능으로 쉽게 포즈를 바꿀 수 있지만 다른 3D 소프트웨어에서 제작한 오브젝트는
기본 관절이 설정되어있지 않거나 콜라다 파일로 호환했을 때 손실되는 부분이 있을 수 있기 때문에,
이 메뉴를 이용해 오브젝트의 체형을 바꿉니다.
이 때, 오브젝트를 몰프하기 위해선 2개 이상의 OBJ 파일이 필요하며, 서로 동일한 메시 구조를 가져야 합니다.
이 메뉴는 궁극적으로, 다른 3D 소프트웨어의 오브젝트를 아바타로 불러와 의상을 입히고,
포즈를 바꾸기 위해 사용합니다.


Location

OBJ Import

메인 메뉴 ▶ 파일 ▶ 불러오기 ▶ OBJ 

몰프 대상 열기

OBJ Import 옵션창 ▶ 물체 유형 ▶ 몰프 대상으로 불러오기


Operation

  1. 몰핑할 OBJ 파일을 2개 준비합니다.

  2. 먼저 해당 경로를 따라갑니다:

    메인 메뉴 ▶ 파일 ▶ 불러오기 ▶ OBJ

    → 파일 열기 창이 열립니다.

  3. 준비한 파일 중 먼저 부를 OBJ파일을 선택하고  확인을 클릭합니다.
    → OBJ 불러오기 창이 열립니다.

  4. OBJ 불러오기 옵션 항목을 설정한 뒤  확인을 클릭합니다.

  5. 그리고 해당 경로를 따라갑니다:

    메인 메뉴 ▶ 파일 ▶ 불러오기 ▶ OBJ 

    → 파일 열기 창이 열립니다.

  6. 준비한 파일 중 나머지 OBJ파일을 선택하고  확인을 클릭합니다.
    → 몰프 대상 불러오기 창이 열립니다.

  7. 해당 경로를 따라갑니다:

    OBJ Import 옵션창 ▶ 물체 유형 ▶ 몰프 대상으로 불러오기

  8. 나머지 상세 항목을 설정하고  확인을 클릭합니다.

    ※ 참조: 불러올 OBJ 파일 경로에 #(특수 문자)이 들어가 있는 경우 해당 파일이 정상적으로 로드되지 않을 수 있습니다.

 

부자재로 불러오기

Objective

다른 3D 소프트웨어에서 제작한 OBJ 파일을 의상을 입히는 아바타 외에 주변 환경을 구성하는 배경, 소품으로도 사용할 수 있습니다. 하지만, 같은 파일을 아바타로 로드했을 때는 의상이 대상 물체를 아바타로 인식해 그 위에 걸쳐지지만,
배경이나 소품으로 불러온 경우에는 의상이 물체로 인식하지 못하고 그대로 통과하게 됩니다.


Location

OBJ Import

메인 메뉴 ▶ 파일 ▶ 불러오기 ▶ OBJ 

배경/소품으로 불러오기

OBJ Import 옵션창 ▶ 물체 유형 ▶ 부자재로 불러오기


Operation

  1. >해당 경로를 따라갑니다:

    메인 메뉴 ▶ 파일 ▶ 불러오기 ▶ OBJ

    → 파일 열기 창이 열립니다.

  2. 배경/소품으로 부를 OBJ 파일을 선택하고 확인을 클릭합니다.
    → OBJ 불러오기 창이 열립니다.

  3. 물체 유형에서 부자재로 불러오기를 선택합니다

  4. 나머지 세부 항목을 설정하고 확인을 클릭합니다.

아바타로 불러오기

Objective

다른 3D 소프트웨어에서 제작한 OBJ 파일을 의상을 입히는 아바타로 사용할 수 있습니다. OBJ 파일을 아바타로 로드 하면 의상이 대상 물체를 아바타로 인식해 그 위에 걸쳐집니다.


Location

OBJ Import

메인 메뉴 ▶ 파일 ▶ 불러오기 ▶ OBJ 

배경/소품으로 불러오기

OBJ Import 옵션창 ▶ 물체 유형 ▶아바타로 불러오기


Operation

  1. >해당 경로를 따라갑니다:

    메인 메뉴 ▶ 파일 ▶ 불러오기 ▶ OBJ

    → 파일 열기 창이 열립니다.

  2. 배경/소품으로 부를 OBJ 파일을 선택하고 확인을 클릭합니다.
    → OBJ 불러오기 창이 열립니다.

  3. 물체 유형에서 아바타로 불러오기를 선택합니다

  4. 나머지 세부 항목을 설정하고 확인을 클릭합니다.

Go back to the List of Contents

도움이 되었습니까?
0명 중 0명이 도움이 되었다고 했습니다.

댓글

댓글을 남기려면 로그인하세요.