メインコンテンツへスキップ

CLO ヘルプセンター

どのようなご用件でしょうか?

SEAM PROBLEM EXPORTING IN BLENDER

コメント

  • pabloquintana

    Mattia, from what you show here, the multiresolution is doing what is supposed to when creating subdivisions. It will round the corners if you don't have supporting loops.

    So here are my thoughts:

    1. Why do you need to smooth out the mesh in Blender? Why not decrease the particle distance in CLO so the drape is more real, and then export as Quads to Blender. No need to subdivide.

    2. Multiresolution modifier is used mostly with sculpting. Smoothing is done generally with the Subdivision Surface modifier.

    Can you elaborate further?

     

    P

    1
  • pabloquintana

    What about here?

     

    https://www.clo3d.com/company/newsdetail/198

    1
  • falmouth

    Hi Mattia,

    Yes all done in Clo. You may need to change the settings of your topstitching to make them more obvious.

    This is Clo:

     

    And I exported using these settings:

    and this is what it looks like in Blender:

    Again, just quick examples, but if you separate by material in Blender, you will be able to apply different settings to the different fabrics:subdivide, displacement etc.

    The stitches are quite high-poly though (in comparison to the rest of the model if you use standard particle distance), so you may want to do some tests because if you decide to separate them, the stitches will not necessarily conform to the surface if you subdivide the fabric and not the stitches.

    Have I explained that correctly?

    Adam

     

    1
  • falmouth

    Hi Mattia,

    I'll do a video later today if I get a chance.

    Adam

    1
  • falmouth

    You could try welding the seams on export. Maybe separate the parts by materials.

    Adam

    0
  • Mattia Buccarelli

    pabloquintana i didn't know about the existence of particles to smooth the fabric.  Thanks I decreased it to 5 but the mesh still has some flaws. Even in quads.

    the multyres and the sub surface are very similar in blender, in this circumstance it makes no difference which one you use. Anyhow they do the same job as decreasing particles in Clo.

    The main problem remains: Even if i don't apply any modifier the seams seem open.

    falmouth I'm sorry but i don't think i understand

    0
  • pabloquintana

    What is the purpose of using any of the subdivision modifiers in Blender if you already have a smooth surface from CLO? Again, the modifiers are doing what they are supposed to do with the underlying mesh.

    What is the purpose to export it to Blender?

    Also, I notice you are using a thin export from CLO. If you export as Thick you won't see the gaps, but again, I'm not sure what you are trying to accomplish.

    P

    0
  • ottoline

    You can get perfect edges and seam normal's in blender using CLO3D thin mesh garment exports. Where you need to place some thought is working in non-destructive manner /workflow between CLO3D and Blender > exporting a thin welded mesh. And importantly naming your patterns and materials well so you get all this data flowing into blender. So make sure you set both your CLO3D settings and blender modifier stack to match. That way you get perfect seam transition including all normal's by making sure the thickness modifier in the blender stack matches the CLO3D setting on the clothing patterns. So understanding how these work together will  allow you to get exact joints. In addition blender has the normal settings and modifier that can make all seam edges respond the same as they do in CLO3D. You can even toss out the stitching into blender as a bake-down layer.

     

    You do need the subd modifier in the blenders stack, and also the smooth and bevel modifier, as these are crucial settings to get the exact result you see in CLO3D on the seam joints. So I would make sure you talk to a Blender user whom appreciates why these are important items. To not have them will cause you hell on earth with your model import.

    There is no need to do ANY editing of the mesh from CLO3D, to get all this working. It' is in fact extremely simple, drag and drop to any and all CLO3D garments and they will come into blender perfectly with all seams, junctions thickness and elements (including stitching) working precise to the CLO3D render view.

     

     

     

    0
  • falmouth

    When you export the model, select 'thin' and 'weld' in the export dialog. 


    Then in Blender it's all joined together. If the particle distance is small enough you shouldn't need to subdivide, but if you do the seams can look a bit odd at the edge if you use Catmull Clark and if you use simple it can look a bit faceted, so you can split parts by material if you need to (also stitches etc so they don't get too mad when you subdivide) and add modify separate parts etc. and it can all sit together quite nicely.

     

    0
  • falmouth

    That's not a well-designed model by the way, that's just a quick example :)

    Adam

    0
  • Mattia Buccarelli

    falmouth Unfortunately this is what i see in blender if i flag single object, weld, thin

    the model is made in one piece.

    How can i make this looks like a real garment divided in his parts?

    0
  • Mattia Buccarelli

    pabloquintana 

    Your advice worked. If i flag on thick the seam looks better welded. But when i use the sub surface the corners open.

    Now i'll show you the purpose of using subsurface:

    If i bring the particles to a very low value, like you told me, in addition to creating a big calculation problems to my computer, it doesn't solve the mesh softness issue anyway:

    This is exported at a low particles distance value without subsurface:

    and this is exported with an higher particles from clo but with the subsurface in blender:

    As you can see the result is better.

    This is the result that i'm trying to accomplish. But i still have the problem that i have to manually weld the collar and the sleeves, that open when i apply the subsurface.

    If the parts where closed it would not happen. 

    0
  • pabloquintana

    Mattia, I'd say that you should work in CLO, learn how to make your garments look good there, and not try to use a different software to cover for you can't do correctly in the source application.

    You are putting time and effort to correct a problem that is generated by not using CLO correctly, instead of using that same effort to fix it at the source. You are just amplifying your problem across the pipeline. In CLO you can use things like strengthening or use different fabrics amongst several other things.

    That is my suggestion. If you insist in trying to smooth the fabrics in Blender I believe that falmouth instructions are  pretty clear. You need to assign different materials in CLO for the collar and then while in Blender do a selection by materials so Blender knows how to separate them and then you can have the collar as a different mesh.

    Let us know how did it go.

     

    P

    0
  • Mattia Buccarelli

    Hi pabloquintana

    You' right i should emprove my Clo skills but the problem is that this is my first approach to Clo and i have non idea how to find the informations.

    I'm trying to find the correct workflow to create garment and render amazing scenes in Blender. But unfortunately there is not too mutch around the web for how to proceed for this dialogue Clo/Blender

    some suggestions to understand how to proceed?

    0
  • Mattia Buccarelli

    Thanks ottoline. I rally appriciate. I have no idea how to do the things you wrote.

    0
  • Mattia Buccarelli

    Hi falmouth !

    Please can u tell me if the stitches of the model you posted above are made in clo?

    Because when i import in blender a Clo file with stitches this is what i see:

    They look like a one piece interrupted in some points. 

    Thanks.

    0
  • Mattia Buccarelli

    falmouth thanks for the reply but i cant reach your own result. Not even in Clo.

    This is the stitches i see in clo with your same settings: 

    look like a flat texture but my stitches setting is on obj. In your picture above look more like a 3D object. 

    And when i export the file with the settings that you showed me, and i import it in blender this is what i see:

    Stitches are represented by nurbes. You know why that happen? 

     

    0
  • Mattia Buccarelli

    Thanks a lot falmouth

    0
  • Mattia Buccarelli

    Sorry falmouth the proble is that i hadn't seen that you exported in OBJ.

    I was exporting in FBX and  those settings doesn't work in FBX.

    In OBJ it work!

    0
サインインしてコメントを残してください。