Skip to main content

CLO Help Center

How can we help you?

Graphics Card Issue During Remote Desktop Session


  • ikafx

    This is default behavior and limitation to Microsoft Remote Desktop.

    This is due to how RDP works. It creates a virtualized desktop version of the host machine that only uses software OpenGL which doesn't use the same extensions required when running in hardware mode. RDP sends 2D bitmap images from the host to the remote client. 

    Microsoft is always working on improving RDP and has a way to make it use the h.264/AVC 444 hardware encoding. On Windows 10 Start the Group Policy Editor by clicking the Windows button and typing gpedit.msc then under Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Remote Session Environment : 1. Prioritize H.264/AVC 444 Graphics mode for Remote Desktop connections. When enabled on the RDP Server, the H.264/AVC 444 mode will be prioritized when the RDP 10 client and server both support AVC/H.264 and support the AVC 444 mode.

    Edit: I checked on my Windows 10 machine and there is a second option that needs to be enabled. Configure H.264/AVC hardware encoding for Remote Desktop Connections. Double click on both the Prioritize and Configure and choose Enable and Apply

    If the above doesn't work you can bypass the error by having Clo running on the host machine first which initiates the Hardware Graphics Card for OpenGL. Then when you RDP the session will only need to send the 2D bitmap images of the host to your client machine when RDP defaults to the software encoding. 

    If you are wanting a different behavior then you would need a different solution such as that is capable of sending advanced OpenGL over a remote session.  

    Citrix XenDesktop which supports advanced 3D & CAD applications is an inexpensive option or something like Splashtop might work. Each have trial versions that you can try to make sure they meet your needs.  

  • ekaterinareshetnyak

    I get the same error, only when the program is turned on normally on a laptop ...
    The drivers are new
    Have you solved your problem?
    Help if everything worked out

  • ikafx

    Microsoft End of Life RemoteFX last year due to a security vulnerability. update-to-disable-and-remove-the-remotefx-vgpu-component-in-windows-bbdf1531-7188-2bf4-0de6-641de79f09d2

    I do not RDP in to my personal computer to run CLO. However I had the graphics problem with RDP for other applications for my work computer. Everything works now but I have TeamViewer running in the background on my work computer in the event RDP fails. It is set up for unattended access which you set a complex password in settings. If RDP fails or is unable to start an application I just use TeamViewer to remotely log in and then either start the application or run it through TeamViewer. 

    That is the only fix that I know of without shelling out $$$ for a Virtual Desktop Infrastructure (VDI) solution. With COVID-19 restrictions there might be more competitive pricing from companies the sale VDIs. 


Please sign in to leave a comment.