CLO HELP CENTER

How can we help you?

3D File (OBJ) Import/Export

Follow

List of Contents 

OBJ Import/Export

Load as Garment

Load as Morph Target

Load as Trim

Load as Avatar

 

OBJ Import/Export

Objective

An OBJ file is used when saving Scene and Props that organize Avatar and surrounding environment. 
If the OBJ type is an Avatar, the OBJ file is able to wear Garments but if it is a Trim, the Garment passes through it as it does not recognize it as an objectFor detailed instruction on how to use OBJ files as Trims, refer to Load As Trim.

Furthermore, OBJ files with the same Mesh structure (net-shaped structure expresses 3D objects) is able to be "Morphed" to change Avatar's appearance. 
“Morphing” refers to slowly changing the appearance of one object into another, and this function can be used to change Avatar's poses or body type. This function is useful when changing Poses of an Avatar in Garments. For detailed instruction, refer to Load as Morph Target.

Garments made with CLO are able to be formatted/imported in *.obj file and they are compatible with other 3D software. When exporting Garments in an *.obj file, a *.mtl file is also created, and this *.mtl file saves material information of the Garment.


Location

OBJ Import

Main Menu ▶ File ▶ Import ▶ OBJ  


Additional OBJ Import

Main Menu ▶ File ▶ Import (Add) ▶ OBJ 


OBJ Export 

Main Menu ▶ File ▶ Export ▶ OBJ


Selected OBJ Export

Main Menu ▶ File ▶ Export ▶ OBJ (Selected)


Operation

OBJ Import

  1. Follow the indicated guideline:

    Main Menu ▶ File ▶ Import ▶ OBJ

    → Open File window appears.

  2. Select a file and click OK.
    → Import OBJ window appears.

  3. Set details and click OK.

    ※ Note: 

    OBJ Import Detail Settings

    Object Type

    Load as Avatar

      Imports an object as an avatar and replaces it with the original avatar.

      Add Arrangement Points &BVs: Turn on this option to generate Bounding Volumes and Arrangement Points fit to the imported OBJ (ver4.2.0).
      ※Note: This option works properly only when imported OBJ is either in T or A pose and below error message appears when this function cannot be applied properly.
      "Arrangement Points were not fitted to the avatar. The avatar must be in a T-pose or A-pose."

    00__1_.jpg  

    Load as Trim   Due to nonfunctional collision detection, objects pass through garments (ver3.0.0).
    Load as Garment

      Import an object as a 3D Garment.

      Trace 2D Patterns from UV Map: Toggle on this option to generate Patterns based on UV Map information (ver4.2.0).

    Load as
    Morph Target
      Morphs the original object into the object designated as the Morph Target. Enter the Transition Frame Count. The higher the frame count, the slower the morphing process.
    Scale   Manually enters values or selects the desired unit.
    Axis Conversion   Changes the directions of each axis of an object.
      When the OBJ is placed below the ground, please toggle on Align Bottom to Ground option to pull up the OBJ file above the ground (ver4.2.0). 


OBJ Additional Import

  1. Follow the indicated guideline:

    Main MenuFileImport (Add) OBJ 

    The Add File window appears.

  2. Set details and click OK.

OBJ Export

  1. Follow the indicated guideline:

    Main Menu File Export OBJ (Selected)

    → Save File window appears.

  2. Select desired location to store, and click Save.
    → Export OBJ window appears.

  3. Set details and click OK.

    ※ Note: 

    OBJ Export Detail Settings

    Object

     

     

     

      Select All Patterns: Select/Deselect all Patterns.
      Individual selection is available on the drop-down menu on the right (ver2.2.0).
     
      ※ Note:
     If OBJ(Selected) is utilized, selected Patterns are being checked in the 3D and 2D window
    .
     
      Select All Avatars:
     Select/Deselect all Avatars/Objects. Individual selection is available on the drop-down menu on the right (v
    er2.2.0).

      Select All Graphics/Top-stitches: Select/Deselect all Graphics/Top-stitches. Individual selection is available on the drop-down menu on the right (ver2.2.0).

      Single Object

      Exports selected object as a single object.

      

      Multiple Objects

      Exports selected object as multiple objects.

      

      Unweld

      Exports Vertex(points of mesh) of sewn pattern parts as multiple objects.

      

      Weld

      Combines Vertex (points of mesh) of sewn pattern parts together as one point.

      

    Weld Selected Pattern: Weld sewing-lines of selected patterns.

      Thin

      Ensures thickness is not exported to Geometry even if the value is increased beforehand.

      

      Thick 

      Exports thickness value to Geometry.

      ※ Note: Thickness is available to be exported when pattern's mesh is Quad (ver2.3.0).

      

    Combined UV Coordinates
    Include Internal Shape: Includes internal line and/or shape information in export (ver2.3.0).
    Scale   Adjusts scale of file being exported when a value is entered or desired unit from 'Unit in file to import' is selected.
    Axis Conversion   Changes directions of object's each axis.
    File   Save with Texture File (*.zip): Exports .obj file, .mtl file, and texture images
      used in the garment as one compressed file when exporting animation.
      Diffuse Color Combined on Texture: When color is applied to the texture, the color is blended into the texture when exporting (ver4.2.0).
      Exclude Ambient Map & Color (Modo): Ambient Map and color are excluded when exporting (ver4.2.0).
      Save with Alpha Map: Alpha Map is included when exporting (ver4.2.0).
      Save with Meta Data (*.xml) : Exports garment's patter(Mesh), physical property and sewing information as Meta Data (ver2.3.0).
      Diffuse Color Combined on Texture: Combine and save garment's texture image and color as a single image (ver2.2.0).
      Exclude Ambient Color (for Modo): Exclude Ambient color value when saving materials.


    ※ Note: 

    OBJ Export Updates

    Internal Line(s)/Shape(s) export (including FBX).

    Thickness export for Quad Mesh.
    Front, side and back meshes separate export.
 

Load as Garment

Objective

Import and simulate OBJ files from other 3D software programs (Maya, 3DS MAX and etc). 


Location

Main Menu File Import (Add)OBJ to Garment


Operation

  1. Follow the indicated guideline:

    Main MenuFileImport (Add) OBJ to Garment

    → Open File window appears.

  2. Select a file and click OK.
    → OBJ to Garment window appears.

  3. Set details and click OK.


Load as Morph Target

Objective

Morph uses two different OBJ files to slowly change object's appearance. CLO's default avatars can be modified at Change Avatar Size menu or posed with Show X-Ray Joints function, other 3D software may not have basic Joints set for designed objects, parts may be lost when creating a compatible COLLADA file. As such, this menu can be used to change the object's body type. At least two *.obj files with the same Mesh structure are needed to morph the object. Use this menu to import objects from different 3D software as Avatars, and dress them or change their Poses. 

00000.png


Location

Import OBJ

Main Menu ▶ File ▶ Import ▶ OBJ 

Open Morph Target

OBJ Import Options Window ▶ Object Type ▶ Load as Morph Target


Operation

  1. Choose two *.obj files to morph.

  2. Follow the indicated guideline:

    Main Menu ▶ File ▶ Import ▶ OBJ 

    → Open File window appears.

  3. Select the first file to import and click OK.
    → Import OBJ window appears.

  4. Set details and click OK.

  5. Follow the indicated guideline:

    Main Menu ▶ File ▶ Import ▶ OBJ 

    → Open File window appears.

  6. Select the second file to import and click OK.
    → Open Morph Target window appears.

  7. Follow the indicated guideline:

    OBJ Import Options Window Object Type Load as Morph Target

  8. Set details and click OK.

    ※ Note: File name with #(special character) is not going to be loaded.

 

Load as Trim

Objective

Use *.obj files designed in other 3D software to organize Trims as well as the Avatars in Garments. When loading a file as an Avatar, the Garment registers the object as an Avatar and allows to drape on top of it, however when the same file is loaded as Trims, the Garment does not register it as an object therefore it passes through it. 


Location

OBJ Import

Main Menu ▶ File ▶ Import ▶ OBJ 

Import as Scene/Prop

OBJ Import Options Window ▶ Object Type ▶ Load as Trim


Operation

  1. Follow the indicated guideline:

    Main Menu
    FileImportOBJ 

    → Open File window appears.

  2. Choose file to import and click OK.
    → Import OBJ window appears.

  3. Select Load as Trim in Object Type.

  4. Set details and click OK.


     

Load as Avatar

Objective

Use *.obj files designed in other 3D software to use as Avatars in CLO. When loading a file as an Avatar, the Garment registers the object as an Avatar and allows to drape on top of it.


Location

OBJ Import

Main Menu ▶ File ▶ Import ▶ OBJ 

Import as Scene/Prop

OBJ Import Options Window ▶ Object Type ▶ Load as Avatar


Operation

  1. Follow the indicated guideline:

    Main Menu
    FileImportOBJ 

    → Open File window appears.

  2. Choose file to import and click OK.
    → Import OBJ window appears.

  3. Select Load as Avatar in Object Type.

  4. Set details and click OK.

 

Was this article helpful?
2 out of 2 found this helpful

Comments

Please sign in to leave a comment.

  • Avatar
    lenaaspeslagh93

    Hi!
    I don't understand the term 'UV map tracing'. Can anyone explain this to me?